Cînd ţi se buşeşte login-ul…

Mă trezesc şi eu, într-o zi de sîmbătă, după două petreceri pe care le-am servit vineri seara, în miezul zilei, pe la unu şi ceva. Într-un final, deschid laptopul, dau click pe bookmark-ul care trimite direct la Dashboard-ul WordPress-ului şi se încarcă wp-login.php. Pînă aici, toate bune şi frumoase, îmi zic. Se mai întîmplă să expire cookie-ul care ţine minte datele de login.

Scriu userul şi parola, bifez căsuţa pentru reţinerea lor şi… mă redirectează spre acelaşi wp-login.php. Mă uit lung, încerc din nou cu parola veche, acelaşi lucru. Dau click pe “Lost your password?“, îmi trimite link de confirmare pe mail, dau click pe el, îmi trimite parolă nouă, dau să mă loghez, nimic. În loc să facă redirectare către /wp-admin/index.php, mă trimite înapoi la wp-login.php.

Caut pe Google detalii despre ce neam de bug o mai fi şi ăsta, găsesc vreo trei posibile explicaţii pentru versiuni mai vechi de 2.7, încerc să înlocuiesc wp-login.php cu altul, tot de 2.7, nu rezolv nimic, încerc să îl înlocuiesc cu unul de 2.6.5 şi tot nu merge. Salvez wp-config.php şi îl înlocuiesc cu unul de WP 2.7, login-ul nu merge, mi se buşesc diacriticele. Întreb pe Twitter, nu răspunde nimeni. Îl sun pe Alex Negrea, habar n-are.

Soluţia? Am şters tot ce înseamnă directoare wp-admin şi wp-includes de pe server şi tot ce înseamnă fişiere de WordPress, mai puţin wp-config.php. Uploadez din nou WordPress-ul, mai puţin directorul wp-content şi fişierul wp-config.php. Dau click pe acelaşi bookmark, merge.

Prin urmare, dacă păţeşte cineva ceva similar, singura modalitate de a rezolva problema este… o reinstalare. Deh!

Dacă îţi place acest blog şi vrei să-l susţii, cumpără de la eMag folosind acest link.

5 comentarii

  1. e de la firefox. daca incercai cu alt browser, mergea

  2. La mine cand il apuca damblaua, am pagina alba in loc de wp-admin, si orice i-as face nu se intampla nimic pana nu suprascriu toate fisierele.

  3. Bine că a mers aşa, mă, dar oricum, ciudată problemă…

  4. Aceasi problema ca si a ta, doar ca si dupa rescrierea tuturor fisierelor inafara de folderul wp-content si fisierul wp-config, problema persista.

    Vreo ideea, inafara de cea la care ma gandesc si eu ? (reinstalare completa)